What to do if you get the Joomla error: "Component Install: DB function reports no errors" "Error installing component"

If you get the errors "Component Install: DB function reports no errors" and "Error installing component" it was probably because a Joomla uninstall failed or you did a manual uninstall/manual deletion of a component and are trying to reinstall it.

Fortunately I know what's going wrong an how to fix it: Horray!


It is not uncommon, you install a buggy Joomla extension and it didn't work well so you uninstall it or manually remove it and when you go the extension manager and try to upload and install it again. BAM you get the errors: "Component Install: DB function reports no errors" and "Error installing component".

All you need to do is make one small edit to the database that Joomla uses and you should be ok to install the component again (without the "Component Install: DB function reports no errors" error appearing). Don't be too afraid if you have never edited your Joomla database before just follow my instructions exactly and you should be all right.

Before we start, backup you Joomla database. I'm happy to help you with the "Component Install: DB function reports no errors" error but I don't want anyone to come crying to me because the lost their whole site messing about in the database. SERIOUSLY: Backup your Joomla Database before you do anything I'm about to tell you.


Edit the Database:

Log on to your hosting account, control panel or whatever and click on the phpMyAdmin icon (I can't tell you where it is because that varies according to web host). You will need to login to you phpMyAdmin account.

phpmyadmin icon in conrol panel


Once logged in to phpMyAdmin click on the database which corresponds to the Joomla site which has the "Component Install: DB function reports no errors"/
"Error installing component" problem.

phpmyadmin databases



Now click on jml_assets

phpmyadmin Joomla assets


Look in the list on the pane to the right and find the name of the component which causes the error whenever you try and install it. It will start with "com_". Make sure you are absolutely sure about the name of the component before you delete it because deleting other component assets could have devastation effects on you site.

delete



All you have to do is delete this asset (by clicking on delete) and your good to go. Yes, thats right, after you delete that problimatic entry in the database you should be able to reinstall the component without getting the "Component Install: DB function reports no errors" and "Error installing component" errors.

Additional:

One last thing, if it does not work remember to:
1) Clear you web browser cache
2) Clear the Joomla cache (from the administrator backend)
3) Do a global checkin (Site > Maintenance > Global Checkin)

Any comments? Has it fixed your "Component Install: DB function reports no errors" nightmare? Let me know!

Posted in Joomla